Jenkins vSphere Plugin disables SSL/TLS certificate validation by default
CVE-2018-1000151GHSA-vq7p-f4fv-rr5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:vsphere-cloud 2.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:vsphere-cloud
- Affected
- <= 2.16
- Fixed in
- 2.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vq7p-f4fv-rr5x lists affected ranges: Maven org.jenkins-ci.plugins:vsphere-cloud >=0 <=2.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2018-1000151: 0.42% estimated exploitation activity in the next 30 days; percentile 36.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A man in the middle vulnerability exists in Jenkins vSphere Plugin 2.16 and older in VSphere.java that disables SSL/TLS certificate validation by default. vSphere Plugin 2.17 now has SSL/TLS certificate validation enabled by default.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vq7p-f4fv-rr5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000151 Advisory: Jenkins vSphere Plugin disables SSL/TLS certificate validation by default IDs: CVE-2018-1000151, GHSA-vq7p-f4fv-rr5x Record: https://patchnext.com/advisories/cve-2018-1000151 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:vsphere-cloud 2.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:vsphere-cloud: affected <= 2.16; fixed in 2.17 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:vsphere-cloud: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:vsphere-cloud. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vq7p-f4fv-rr5x (GitHub-reviewed advisory GHSA-vq7p-f4fv-rr5x lists affected ranges: Maven org.jenkins-ci.plugins:vsphere-cloud >=0 <=2.16) Commands are suggestions: review each one before running it.
Loading voting…