Electron Vulnerable to Code Execution by Re-Enabling Node.js Integration
CVE-2018-1000136GHSA-8xwg-wv7v-4vqp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 2.0.0-beta.5, 1.8.4, 1.7.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- >= 2.0.0-beta.1, < 2.0.0-beta.5>= 1.7.0, < 1.7.13>= 1.8.0, < 1.8.4
- Fixed in
- 1.7.13, 1.8.4, 2.0.0-beta.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8xwg-wv7v-4vqp lists affected ranges: npm electron >=1.7.0 =1.8.0 =2.0.0-beta.1 <2.0.0-beta.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xwg-wv7v-4vqp lists affected ranges: npm electron >=2.0.0-beta.1 =1.7.0 =1.8.0 <1.8.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-1000136: 5.08% estimated exploitation activity in the next 30 days; percentile 92.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability has been discovered which allows Node.js integration to be re-enabled in some Electron applications that disable it. For the application to be impacted by this vulnerability it must meet all of these conditions - Runs on Electron 1.7, 1.8, or a 2.0.0-beta - Allows execution of arbitrary remote code - Disables Node.js integration - Does not explicitly declare webviewTag: false in its webPreferences - Does not enable the nativeWindowOption option - Does not intercept new-window events and manually override event.newGuest without using the supplied options tag Recommendation Update to electron version 1.7.13, 1.8.4, or 2.0.0-beta.5 or later. If you are unable to update your Electron version can mitigate the vulnerability with the following code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8xwg-wv7v-4vqp
- Revision 1 · created ·
Published from osv record GHSA-8xwg-wv7v-4vqp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000136 Advisory: Electron Vulnerable to Code Execution by Re-Enabling Node.js Integration IDs: CVE-2018-1000136, GHSA-8xwg-wv7v-4vqp Record: https://patchnext.com/advisories/cve-2018-1000136 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 2.0.0-beta.5, 1.8.4, 1.7.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected >= 2.0.0-beta.1, < 2.0.0-beta.5; >= 1.7.0, < 1.7.13; >= 1.8.0, < 1.8.4; fixed in 1.7.13, 1.8.4, 2.0.0-beta.5 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8xwg-wv7v-4vqp (OSV record GHSA-8xwg-wv7v-4vqp lists affected ranges: npm electron >=1.7.0 =1.8.0 =2.0.0-beta.1 <2.0.0-beta.5 (fixed)) - Verified: https://github.com/advisories/GHSA-8xwg-wv7v-4vqp (GitHub-reviewed advisory GHSA-8xwg-wv7v-4vqp lists affected ranges: npm electron >=2.0.0-beta.1 =1.7.0 =1.8.0 <1.8.4) Commands are suggestions: review each one before running it.
Loading voting…