Weak Password Requirements in UnboundID LDAP SDK
CVE-2018-1000134GHSA-qwq9-8rpf-8mp7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.unboundid:unboundid-ldapsdk 4.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.unboundid:unboundid-ldapsdk
- Affected
- >= 1.1.0, < 4.0.5
- Fixed in
- 4.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qwq9-8rpf-8mp7 lists affected ranges: Maven com.unboundid:unboundid-ldapsdk >=1.1.0 <4.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-1000134: 4.65% estimated exploitation activity in the next 30 days; percentile 91.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
UnboundID LDAP SDK version from commit 801111d8b5c732266a5dbd4b3bb0b6c7b94d7afb up to commit 8471904a02438c03965d21367890276bc25fa5a6, where the issue was reported and fixed contains an Incorrect Access Control vulnerability in process function in SimpleBindRequest class doesn't check for empty password when running in synchronous mode. The issue can result in ability to impersonate any valid user. This attack appear to be exploitable via Providing valid username and empty password against servers that do not do additional validation as per https://tools.ietf.org/html/rfc4513#section-5.1.1. This vulnerability appears to have been fixed in commit 8471904a02438c03965d21367890276bc25fa5a6.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qwq9-8rpf-8mp7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000134 Advisory: Weak Password Requirements in UnboundID LDAP SDK IDs: CVE-2018-1000134, GHSA-qwq9-8rpf-8mp7 Record: https://patchnext.com/advisories/cve-2018-1000134 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.unboundid:unboundid-ldapsdk 4.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.unboundid:unboundid-ldapsdk: affected >= 1.1.0, < 4.0.5; fixed in 4.0.5 ## Suggested inspection (read-only) - Maven com.unboundid:unboundid-ldapsdk: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.unboundid:unboundid-ldapsdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qwq9-8rpf-8mp7 (GitHub-reviewed advisory GHSA-qwq9-8rpf-8mp7 lists affected ranges: Maven com.unboundid:unboundid-ldapsdk >=1.1.0 <4.0.5) Commands are suggestions: review each one before running it.
Loading voting…