Skip to content

← Actionable
Critical, CVSS 9.3amended

Mercurial Incorrect Access Control vulnerability

CVE-2018-1000132GHSA-4mr4-7vjv-9hm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mercurial 4.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2018-1000132: 2.62% estimated exploitation activity in the next 30 days; percentile 85.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4mr4-7vjv-9hm6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4mr4-7vjv-9hm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000132

Advisory: Mercurial Incorrect Access Control vulnerability
IDs: CVE-2018-1000132, GHSA-4mr4-7vjv-9hm6
Record: https://patchnext.com/advisories/cve-2018-1000132 (revision 3, source checked 26 Oct 2026, 13:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mercurial 4.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mercurial: affected < 4.5.1; fixed in 4.5.1

## Suggested inspection (read-only)
- `python -m pip show mercurial`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mercurial.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4mr4-7vjv-9hm6 (OSV record GHSA-4mr4-7vjv-9hm6 lists affected ranges: PyPI mercurial >=0 <4.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4mr4-7vjv-9hm6 (GitHub-reviewed advisory GHSA-4mr4-7vjv-9hm6 lists affected ranges: PyPI mercurial >=0 <4.5.1)

Commands are suggestions: review each one before running it.

Loading voting…