Skip to content

← Actionable
Medium, CVSS 5.9

rack-protection gem timing attack vulnerability when validating CSRF token

CVE-2018-1000119GHSA-688c-3x49-6rqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack-protection 2.0.0, 1.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack-protection

    Affected
    < 1.5.5>= 2.0.0.beta1, <= 2.0.0.rc3
    Fixed in
    2.0.0, 1.5.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2018-1000119: 2.40% estimated exploitation activity in the next 30 days; percentile 84.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Sinatra rack-protection versions 1.5.4 and 2.0.0.rc3 and earlier contains a timing attack vulnerability in the CSRF token checking that can result in signatures can be exposed. This attack appear to be exploitable via network connectivity to the ruby application. This vulnerability appears to have been fixed in 1.5.5 and 2.0.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-688c-3x49-6rqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000119

Advisory: rack-protection gem timing attack vulnerability when validating CSRF token
IDs: CVE-2018-1000119, GHSA-688c-3x49-6rqj
Record: https://patchnext.com/advisories/cve-2018-1000119 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack-protection 2.0.0, 1.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack-protection: affected < 1.5.5; >= 2.0.0.beta1, <= 2.0.0.rc3; fixed in 2.0.0, 1.5.5

## Suggested inspection (read-only)
- RubyGems rack-protection: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack-protection.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-688c-3x49-6rqj (GitHub-reviewed advisory GHSA-688c-3x49-6rqj lists affected ranges: RubyGems rack-protection >=0 =2.0.0.beta1 <=2.0.0.rc3)

Commands are suggestions: review each one before running it.

Loading voting…