Skip to content

← Actionable
High, CVSS 8.8amended

Remote Code Execution in electron

CVE-2018-1000006GHSA-w222-53c6-c86p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 1.8.2-beta.4, 1.7.11, 1.6.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    >= 1.7.0, < 1.7.11>= 1.6.0, < 1.6.16>= 1.8.0, <= 1.8.2-beta.3
    Fixed in
    1.7.11, 1.8.2-beta.4, 1.6.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-1000006: 88.84% estimated exploitation activity in the next 30 days; percentile 99.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of electron may be susceptible to a remote code execution flaw when certain conditions are met: 1. The electron application is running on Windows. 2. The electron application registers as the default handler for a protocol, such as nodeapp://. This vulnerability is caused by a failure to sanitize additional arguments to chromium in the command line handler for Electron. MacOS and Linux are not vulnerable. Recommendation Update electron to a version that is not vulnerable. If updating is not possible, the electron team has provided the following guidance: If for some reason you are unable to upgrade your Electron version, you can append -- as the last argument when calling app.setAsDefaultProtocolClient, which prevents Chromium from parsing further options. The double dash -- signifies the end of command options, after which only positional parameters are accepted.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w222-53c6-c86p

  2. Revision 1 · created ·

    Published from osv record GHSA-w222-53c6-c86p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000006

Advisory: Remote Code Execution in electron
IDs: CVE-2018-1000006, GHSA-w222-53c6-c86p
Record: https://patchnext.com/advisories/cve-2018-1000006 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electron 1.8.2-beta.4, 1.7.11, 1.6.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected >= 1.7.0, < 1.7.11; >= 1.6.0, < 1.6.16; >= 1.8.0, <= 1.8.2-beta.3; fixed in 1.7.11, 1.8.2-beta.4, 1.6.16

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w222-53c6-c86p (OSV record GHSA-w222-53c6-c86p lists affected ranges: npm electron >=1.7.0 =1.6.0 =1.8.0 <1.8.2-beta.4 (fixed))
- Verified: https://github.com/advisories/GHSA-w222-53c6-c86p (GitHub-reviewed advisory GHSA-w222-53c6-c86p lists affected ranges: npm electron >=1.7.0 =1.6.0 =1.8.0 <=1.8.2-beta.3)

Commands are suggestions: review each one before running it.

Loading voting…