Cisco node-jose improper validation of JWT signature
CVE-2018-0114GHSA-jfxm-w8g2-4rcv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-jose 0.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-jose
- Affected
- < 0.11.0
- Fixed in
- 0.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfxm-w8g2-4rcv lists affected ranges: npm node-jose >=0 <0.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfxm-w8g2-4rcv lists affected ranges: npm node-jose >=0 <0.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-0114: 42.65% estimated exploitation activity in the next 30 days; percentile 98.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the Cisco node-jose open source library before 0.11.0 could allow an unauthenticated, remote attacker to re-sign tokens using a key that is embedded within the token. The vulnerability is due to node-jose following the JSON Web Signature (JWS) standard for JSON Web Tokens (JWTs). This standard specifies that a JSON Web Key (JWK) representing a public key can be embedded within the header of a JWS. This public key is then trusted for verification. An attacker could exploit this by forging valid JWS objects by removing the original signature, adding a new public key to the header, and then signing the object using the (attacker-owned) private key associated with the public key embedded in that JWS header.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jfxm-w8g2-4rcv
- Revision 1 · created ·
Published from osv record GHSA-jfxm-w8g2-4rcv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-0114 Advisory: Cisco node-jose improper validation of JWT signature IDs: CVE-2018-0114, GHSA-jfxm-w8g2-4rcv Record: https://patchnext.com/advisories/cve-2018-0114 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-jose 0.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-jose: affected < 0.11.0; fixed in 0.11.0 ## Suggested inspection (read-only) - `npm ls node-jose --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-jose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jfxm-w8g2-4rcv (OSV record GHSA-jfxm-w8g2-4rcv lists affected ranges: npm node-jose >=0 <0.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jfxm-w8g2-4rcv (GitHub-reviewed advisory GHSA-jfxm-w8g2-4rcv lists affected ranges: npm node-jose >=0 <0.11.0) Commands are suggestions: review each one before running it.
Loading voting…