Apache Geode OQL method invocation vulnerability
CVE-2017-9795GHSA-6m68-3w55-6mx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.geode:geode-core 1.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.geode:geode-core
- Affected
- >= 1.0.0, < 1.3.0
- Fixed in
- 1.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m68-3w55-6mx4 lists affected ranges: Maven org.apache.geode:geode-core >=1.0.0 <1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-9795: 4.18% estimated exploitation activity in the next 30 days; percentile 90.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When an Apache Geode cluster before v1.3.0 is operating in secure mode, a user with read access to specific regions within a Geode cluster may execute OQL queries that allow read and write access to objects within unauthorized regions. In addition a user could invoke methods that allow remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6m68-3w55-6mx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-9795 Advisory: Apache Geode OQL method invocation vulnerability IDs: CVE-2017-9795, GHSA-6m68-3w55-6mx4 Record: https://patchnext.com/advisories/cve-2017-9795 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.geode:geode-core 1.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.geode:geode-core: affected >= 1.0.0, < 1.3.0; fixed in 1.3.0 ## Suggested inspection (read-only) - Maven org.apache.geode:geode-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.geode:geode-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6m68-3w55-6mx4 (GitHub-reviewed advisory GHSA-6m68-3w55-6mx4 lists affected ranges: Maven org.apache.geode:geode-core >=1.0.0 <1.3.0) Commands are suggestions: review each one before running it.
Loading voting…