Jetty vulnerable to exposure of sensitive information due to observable discrepancy
CVE-2017-9735GHSA-wfcc-pff6-rgc5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-server 9.4.6.v20170531, 9.3.20.v20170531, 9.2.22.v20170606), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty:jetty-server
- Affected
- >= 9.4.0, <= 9.4.5.v20170502>= 9.3.0, <= 9.3.19.v20170502<= 9.2.21.v20170120
- Fixed in
- 9.4.6.v20170531, 9.3.20.v20170531, 9.2.22.v20170606
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wfcc-pff6-rgc5 lists affected ranges: Maven org.eclipse.jetty:jetty-server >=9.4.0 =9.3.0 =0 <=9.2.21.v20170120
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2017-9735: 5.79% estimated exploitation activity in the next 30 days; percentile 93.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jetty through 9.4.x contains a timing channel attack in util/security/Password.java, which allows attackers to obtain access by observing elapsed times before rejection of incorrect passwords.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wfcc-pff6-rgc5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-9735 Advisory: Jetty vulnerable to exposure of sensitive information due to observable discrepancy IDs: CVE-2017-9735, GHSA-wfcc-pff6-rgc5 Record: https://patchnext.com/advisories/cve-2017-9735 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-server 9.4.6.v20170531, 9.3.20.v20170531, 9.2.22.v20170606. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty:jetty-server: affected >= 9.4.0, <= 9.4.5.v20170502; >= 9.3.0, <= 9.3.19.v20170502; <= 9.2.21.v20170120; fixed in 9.4.6.v20170531, 9.3.20.v20170531, 9.2.22.v20170606 ## Suggested inspection (read-only) - Maven org.eclipse.jetty:jetty-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty:jetty-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wfcc-pff6-rgc5 (GitHub-reviewed advisory GHSA-wfcc-pff6-rgc5 lists affected ranges: Maven org.eclipse.jetty:jetty-server >=9.4.0 =9.3.0 =0 <=9.2.21.v20170120) Commands are suggestions: review each one before running it.
Loading voting…