Laravel does not properly constrain the host portion of a password-reset URL
CVE-2017-9303GHSA-rc8x-jrrc-frfv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/laravel
- Affected
- >= 5.4.0, < 5.4.22
- Fixed in
- 5.4.22
Packagist laravel/framework
- Affected
- >= 5.3.0, <= 5.3.31>= 5.4.0, < 5.4.22
- Fixed in
- 5.4.22
Packagist illuminate/auth
- Affected
- >= 5.3.0, <= 5.3.31>= 5.4.0, < 5.4.22
- Fixed in
- 5.4.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rc8x-jrrc-frfv lists affected ranges: Packagist laravel/laravel >=5.4.0 =5.3.0 =5.4.0 =5.3.0 =5.4.0 <5.4.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-9303: 0.96% estimated exploitation activity in the next 30 days; percentile 61.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rc8x-jrrc-frfv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-9303 Advisory: Laravel does not properly constrain the host portion of a password-reset URL IDs: CVE-2017-9303, GHSA-rc8x-jrrc-frfv Record: https://patchnext.com/advisories/cve-2017-9303 (revision 1, source checked 26 Oct 2026, 14:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: laravel/laravel 5.4.22; laravel/framework 5.4.22; illuminate/auth 5.4.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/laravel: affected >= 5.4.0, < 5.4.22; fixed in 5.4.22 - Packagist laravel/framework: affected >= 5.3.0, <= 5.3.31; >= 5.4.0, < 5.4.22; fixed in 5.4.22 - Packagist illuminate/auth: affected >= 5.3.0, <= 5.3.31; >= 5.4.0, < 5.4.22; fixed in 5.4.22 ## Suggested inspection (read-only) - Packagist laravel/laravel: check the installed version with your package manager. - Packagist laravel/framework: check the installed version with your package manager. - Packagist illuminate/auth: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/laravel, laravel/framework, illuminate/auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rc8x-jrrc-frfv (GitHub-reviewed advisory GHSA-rc8x-jrrc-frfv lists affected ranges: Packagist laravel/laravel >=5.4.0 =5.3.0 =5.4.0 =5.3.0 =5.4.0 <5.4.22) Commands are suggestions: review each one before running it.
Loading voting…