Improper Privilege Management in X-Pack
CVE-2017-8446GHSA-m728-qvxh-xfjq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch.plugin:x-pack 5.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.elasticsearch.plugin:x-pack
- Affected
- < 5.5.2
- Fixed in
- 5.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m728-qvxh-xfjq lists affected ranges: Maven org.elasticsearch.plugin:x-pack >=0 <5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2017-8446: 0.69% estimated exploitation activity in the next 30 days; percentile 53.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Reporting feature in X-Pack in versions prior to 5.5.2 and standalone Reporting plugin versions versions prior to 2.4.6 had an impersonation vulnerability. A user with the reportinguser role could execute a report with the permissions of another reporting user, possibly gaining access to sensitive data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m728-qvxh-xfjq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-8446 Advisory: Improper Privilege Management in X-Pack IDs: CVE-2017-8446, GHSA-m728-qvxh-xfjq Record: https://patchnext.com/advisories/cve-2017-8446 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch.plugin:x-pack 5.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.elasticsearch.plugin:x-pack: affected < 5.5.2; fixed in 5.5.2 ## Suggested inspection (read-only) - Maven org.elasticsearch.plugin:x-pack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.elasticsearch.plugin:x-pack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m728-qvxh-xfjq (GitHub-reviewed advisory GHSA-m728-qvxh-xfjq lists affected ranges: Maven org.elasticsearch.plugin:x-pack >=0 <5.5.2) Commands are suggestions: review each one before running it.
Loading voting…