Cloud Foundry UAA Denial of Service through client token revocation endpoint
CVE-2017-8031GHSA-j4p3-2m2h-cv5f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 4.7.1, 4.5.3, 3.20.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.cloudfoundry.identity:cloudfoundry-identity-server
- Affected
- >= 4.6.0, < 4.7.1>= 4.0.0, < 4.5.3< 3.20.1
- Fixed in
- 4.7.1, 4.5.3, 3.20.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j4p3-2m2h-cv5f lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=4.6.0 =4.0.0 =0 <3.20.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-8031: 1.09% estimated exploitation activity in the next 30 days; percentile 65.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Cloud Foundry Foundation cf-release (all versions prior to v279) and UAA (30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1). In some cases, the UAA allows an authenticated user for a particular client to revoke client tokens for other users on the same client. This occurs only if the client is using opaque tokens or JWT tokens validated using the checktoken endpoint. A malicious actor could cause denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j4p3-2m2h-cv5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-8031 Advisory: Cloud Foundry UAA Denial of Service through client token revocation endpoint IDs: CVE-2017-8031, GHSA-j4p3-2m2h-cv5f Record: https://patchnext.com/advisories/cve-2017-8031 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 4.7.1, 4.5.3, 3.20.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected >= 4.6.0, < 4.7.1; >= 4.0.0, < 4.5.3; < 3.20.1; fixed in 4.7.1, 4.5.3, 3.20.1 ## Suggested inspection (read-only) - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j4p3-2m2h-cv5f (GitHub-reviewed advisory GHSA-j4p3-2m2h-cv5f lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=4.6.0 =4.0.0 =0 <3.20.1) Commands are suggestions: review each one before running it.
Loading voting…