Denial of service in XStream
CVE-2017-7957GHSA-7hwc-46rm-65jh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.thoughtworks.xstream:xstream 1.4.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.thoughtworks.xstream:xstream
- Affected
- < 1.4.10
- Fixed in
- 1.4.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hwc-46rm-65jh lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-7957: 4.93% estimated exploitation activity in the next 30 days; percentile 92.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
XStream through 1.4.9, when a certain denyTypes workaround is not used, mishandles attempts to create an instance of the primitive type 'void' during unmarshalling, leading to a remote application crash, as demonstrated by an xstream.fromXML("<void/") call.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7hwc-46rm-65jh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-7957 Advisory: Denial of service in XStream IDs: CVE-2017-7957, GHSA-7hwc-46rm-65jh Record: https://patchnext.com/advisories/cve-2017-7957 (revision 1, source checked 26 Oct 2026, 16:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.thoughtworks.xstream:xstream 1.4.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.thoughtworks.xstream:xstream: affected < 1.4.10; fixed in 1.4.10 ## Suggested inspection (read-only) - Maven com.thoughtworks.xstream:xstream: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.thoughtworks.xstream:xstream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7hwc-46rm-65jh (GitHub-reviewed advisory GHSA-7hwc-46rm-65jh lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.10) Commands are suggestions: review each one before running it.
Loading voting…