Skip to content

← Actionable
Medium, CVSS 6.5

MantisBT vulnerable to CSRF and Open Redirect attacks

CVE-2017-7620GHSA-9x76-mp7r-2xc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.4.1, 2.3.3, 1.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mantisbt/mantisbt

    Affected
    < 1.3.11>= 2.0.0, < 2.3.3>= 2.4.0, < 2.4.1
    Fixed in
    2.4.1, 1.3.11, 2.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2017-7620: 1.36% estimated exploitation activity in the next 30 days; percentile 71.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

MantisBT before 1.3.11, 2.x before 2.3.3, and 2.4.x before 2.4.1 omits a backslash check in stringapi.php and consequently has conflicting interpretations of an initial \/ substring as introducing either a local pathname or a remote hostname, which leads to (1) arbitrary Permalink Injection via CSRF attacks on a permalinkpage.php?url= URI and (2) an open redirect via a loginpage.php?return= URI.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9x76-mp7r-2xc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7620

Advisory: MantisBT vulnerable to CSRF and Open Redirect attacks
IDs: CVE-2017-7620, GHSA-9x76-mp7r-2xc5
Record: https://patchnext.com/advisories/cve-2017-7620 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.4.1, 2.3.3, 1.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mantisbt/mantisbt: affected < 1.3.11; >= 2.0.0, < 2.3.3; >= 2.4.0, < 2.4.1; fixed in 2.4.1, 1.3.11, 2.3.3

## Suggested inspection (read-only)
- Packagist mantisbt/mantisbt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mantisbt/mantisbt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9x76-mp7r-2xc5 (GitHub-reviewed advisory GHSA-9x76-mp7r-2xc5 lists affected ranges: Packagist mantisbt/mantisbt >=0 =2.0.0 =2.4.0 <2.4.1)

Commands are suggestions: review each one before running it.

Loading voting…