Cross-Site Request Forgery in hawtio
CVE-2017-7556GHSA-q4q2-fvwf-6ghv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.hawt:project 1.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.hawt:project
- Affected
- < 1.5.4
- Fixed in
- 1.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4q2-fvwf-6ghv lists affected ranges: Maven io.hawt:project >=0 <1.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-7556: 0.68% estimated exploitation activity in the next 30 days; percentile 52.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
It was found that hawtio contains a CSRF flaw that allows unrelated websites to perform actions as the authenticated user. Attackers could use this vulnerability to trick the user to visit his website that contains a malicious script which can be submitted to hawtio server on behalf of the user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q4q2-fvwf-6ghv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-7556 Advisory: Cross-Site Request Forgery in hawtio IDs: CVE-2017-7556, GHSA-q4q2-fvwf-6ghv Record: https://patchnext.com/advisories/cve-2017-7556 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.hawt:project 1.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.hawt:project: affected < 1.5.4; fixed in 1.5.4 ## Suggested inspection (read-only) - Maven io.hawt:project: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.hawt:project. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q4q2-fvwf-6ghv (GitHub-reviewed advisory GHSA-q4q2-fvwf-6ghv lists affected ranges: Maven io.hawt:project >=0 <1.5.4) Commands are suggestions: review each one before running it.
Loading voting…