Skip to content

← Actionable
Critical, CVSS 9.3amended

Ansible Insertion of Sensitive Information into Log File vulnerability

CVE-2017-7550GHSA-588w-w6mv-3cw5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 2.4.1.0, 2.3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ansible

    Affected
    >= 2.4.0.0, < 2.4.1.0>= 2.3.0.0, < 2.3.3.0
    Fixed in
    2.3.3.0, 2.4.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2017-7550: 3.56% estimated exploitation activity in the next 30 days; percentile 89.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkinsplugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-588w-w6mv-3cw5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-588w-w6mv-3cw5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7550

Advisory: Ansible Insertion of Sensitive Information into Log File vulnerability
IDs: CVE-2017-7550, GHSA-588w-w6mv-3cw5
Record: https://patchnext.com/advisories/cve-2017-7550 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ansible 2.4.1.0, 2.3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ansible: affected >= 2.4.0.0, < 2.4.1.0; >= 2.3.0.0, < 2.3.3.0; fixed in 2.3.3.0, 2.4.1.0

## Suggested inspection (read-only)
- `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ansible.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-588w-w6mv-3cw5 (OSV record GHSA-588w-w6mv-3cw5 lists affected ranges: PyPI ansible >=2.4.0.0 =2.3.0.0 <2.3.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-588w-w6mv-3cw5 (GitHub-reviewed advisory GHSA-588w-w6mv-3cw5 lists affected ranges: PyPI ansible >=2.4.0.0 =2.3.0.0 <2.3.3.0)

Commands are suggestions: review each one before running it.

Loading voting…