Skip to content

← Actionable
Medium, CVSS 5.3

Moodle Unauthorized searching of arbitrary blogs by typing full url

CVE-2017-7490GHSA-9x63-m3cc-qf3g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.2.3, 3.1.6, 3.0.10, 2.7.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.2, < 3.2.3>= 3.1, < 3.1.6>= 3.0, < 3.0.10>= 2.7, < 2.7.20
    Fixed in
    3.0.10, 3.1.6, 3.2.3, 2.7.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2017-7490: 1.05% estimated exploitation activity in the next 30 days; percentile 64.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9x63-m3cc-qf3g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7490

Advisory: Moodle Unauthorized searching of arbitrary blogs by typing full url
IDs: CVE-2017-7490, GHSA-9x63-m3cc-qf3g
Record: https://patchnext.com/advisories/cve-2017-7490 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.2.3, 3.1.6, 3.0.10, 2.7.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.2, < 3.2.3; >= 3.1, < 3.1.6; >= 3.0, < 3.0.10; >= 2.7, < 2.7.20; fixed in 3.0.10, 3.1.6, 3.2.3, 2.7.20

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9x63-m3cc-qf3g (GitHub-reviewed advisory GHSA-9x63-m3cc-qf3g lists affected ranges: Packagist moodle/moodle >=3.2 =3.1 =3.0 =2.7 <2.7.20)

Commands are suggestions: review each one before running it.

Loading voting…