Ansible fails to properly mark lookup-plugin results as unsafe
CVE-2017-7481GHSA-w578-j992-554x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 2.3.1.0, 2.2.3.0, 2.1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ansible
- Affected
- >= 2.3.0.0, < 2.3.1.0< 2.1.6.0>= 2.2.0.0, < 2.2.3.0
- Fixed in
- 2.2.3.0, 2.3.1.0, 2.1.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w578-j992-554x lists affected ranges: PyPI ansible >=2.3.0.0 =0 =2.2.0.0 <2.2.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w578-j992-554x lists affected ranges: PyPI ansible >=2.3.0.0 =0 =2.2.0.0 <2.2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-7481: 4.74% estimated exploitation activity in the next 30 days; percentile 91.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Ansible before versions 2.1.6.0, 2.2.3.0, 2.3.1.0, and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w578-j992-554x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w578-j992-554x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-7481 Advisory: Ansible fails to properly mark lookup-plugin results as unsafe IDs: CVE-2017-7481, GHSA-w578-j992-554x Record: https://patchnext.com/advisories/cve-2017-7481 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ansible 2.3.1.0, 2.2.3.0, 2.1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ansible: affected >= 2.3.0.0, < 2.3.1.0; < 2.1.6.0; >= 2.2.0.0, < 2.2.3.0; fixed in 2.2.3.0, 2.3.1.0, 2.1.6.0 ## Suggested inspection (read-only) - `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ansible. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w578-j992-554x (OSV record GHSA-w578-j992-554x lists affected ranges: PyPI ansible >=2.3.0.0 =0 =2.2.0.0 <2.2.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w578-j992-554x (GitHub-reviewed advisory GHSA-w578-j992-554x lists affected ranges: PyPI ansible >=2.3.0.0 =0 =2.2.0.0 <2.2.3.0) Commands are suggestions: review each one before running it.
Loading voting…