Skip to content

← Actionable
Medium, CVSS 4.8

MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php

CVE-2017-7309GHSA-4w6c-3hcx-rfj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.2.3, 2.1.3, 1.3.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mantisbt/mantisbt

    Affected
    < 1.3.9>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.3
    Fixed in
    1.3.9, 2.1.3, 2.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-7309: 57.32% estimated exploitation activity in the next 30 days; percentile 99.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (admconfigreport.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'configoption' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4w6c-3hcx-rfj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7309

Advisory: MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php
IDs: CVE-2017-7309, GHSA-4w6c-3hcx-rfj5
Record: https://patchnext.com/advisories/cve-2017-7309 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.2.3, 2.1.3, 1.3.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mantisbt/mantisbt: affected < 1.3.9; >= 2.1.0, < 2.1.3; >= 2.2.0, < 2.2.3; fixed in 1.3.9, 2.1.3, 2.2.3

## Suggested inspection (read-only)
- Packagist mantisbt/mantisbt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mantisbt/mantisbt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4w6c-3hcx-rfj5 (GitHub-reviewed advisory GHSA-4w6c-3hcx-rfj5 lists affected ranges: Packagist mantisbt/mantisbt >=0 =2.1.0 =2.2.0 <2.2.3)

Commands are suggestions: review each one before running it.

Loading voting…