Skip to content

← Actionable
High, CVSS 8.8

Rancher Access Control Vulnerability

CVE-2017-7297GHSA-w3x4-9854-95x8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 1.5.3, 1.4.3, 1.3.5, 1.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/rancher/rancher

    Affected
    >= 1.5.0, < 1.5.3>= 1.4.0, < 1.4.3>= 1.3.0, < 1.3.5>= 1.2.0, < 1.2.4
    Fixed in
    1.3.5, 1.5.3, 1.4.3, 1.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-7297: 1.49% estimated exploitation activity in the next 30 days; percentile 74.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w3x4-9854-95x8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7297

Advisory: Rancher Access Control Vulnerability
IDs: CVE-2017-7297, GHSA-w3x4-9854-95x8
Record: https://patchnext.com/advisories/cve-2017-7297 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 1.5.3, 1.4.3, 1.3.5, 1.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/rancher: affected >= 1.5.0, < 1.5.3; >= 1.4.0, < 1.4.3; >= 1.3.0, < 1.3.5; >= 1.2.0, < 1.2.4; fixed in 1.3.5, 1.5.3, 1.4.3, 1.2.4

## Suggested inspection (read-only)
- Go github.com/rancher/rancher: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/rancher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3x4-9854-95x8 (GitHub-reviewed advisory GHSA-w3x4-9854-95x8 lists affected ranges: Go github.com/rancher/rancher >=1.5.0 =1.4.0 =1.3.0 =1.2.0 <1.2.4)

Commands are suggestions: review each one before running it.

Loading voting…