Skip to content

← Actionable
Medium, CVSS 6.1

Pi Cross-site Scripting vulnerability

CVE-2017-7251GHSA-9v3w-m552-m6ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pi/pi 2.6.0-alpha1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist pi/pi

    Affected
    <= 2.5.0
    Fixed in
    2.6.0-alpha1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-7251: 0.98% estimated exploitation activity in the next 30 days; percentile 62.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. The vulnerability exists due to insufficient filtration of user-supplied data (preview) passed to the pi-develop/www/script/editor/markitup/preview/markdown.php URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9v3w-m552-m6ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7251

Advisory: Pi Cross-site Scripting vulnerability
IDs: CVE-2017-7251, GHSA-9v3w-m552-m6ff
Record: https://patchnext.com/advisories/cve-2017-7251 (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pi/pi 2.6.0-alpha1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pi/pi: affected <= 2.5.0; fixed in 2.6.0-alpha1

## Suggested inspection (read-only)
- Packagist pi/pi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pi/pi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9v3w-m552-m6ff (GitHub-reviewed advisory GHSA-9v3w-m552-m6ff lists affected ranges: Packagist pi/pi >=0 <=2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…