Skip to content

← Actionable
Critical, CVSS 9.8amended

OpenStack Nova logs sensitive context from notification exceptions

CVE-2017-7214GHSA-f4g4-cj8f-3cr9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nova 15.0.2, 14.0.5, 13.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nova

    Affected
    >= 13.0.0, < 13.1.4>= 14.0.0, < 14.0.5>= 15.0.1, < 15.0.2
    Fixed in
    13.1.4, 14.0.5, 15.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-7214: 2.30% estimated exploitation activity in the next 30 days; percentile 83.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in exceptionwrapper.py in OpenStack Nova 13.x through 13.1.3, 14.x through 14.0.4, and 15.x through 15.0.1. Legacy notification exception contexts appearing in ERROR level logs may include sensitive information such as account passwords and authorization tokens.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f4g4-cj8f-3cr9

  2. Revision 1 · created ·

    Published from osv record GHSA-f4g4-cj8f-3cr9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7214

Advisory: OpenStack Nova logs sensitive context from notification exceptions
IDs: CVE-2017-7214, GHSA-f4g4-cj8f-3cr9
Record: https://patchnext.com/advisories/cve-2017-7214 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nova 15.0.2, 14.0.5, 13.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nova: affected >= 13.0.0, < 13.1.4; >= 14.0.0, < 14.0.5; >= 15.0.1, < 15.0.2; fixed in 13.1.4, 14.0.5, 15.0.2

## Suggested inspection (read-only)
- `python -m pip show nova`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nova.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f4g4-cj8f-3cr9 (OSV record GHSA-f4g4-cj8f-3cr9 lists affected ranges: PyPI nova >=13.0.0 =14.0.0 =15.0.1 <15.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-f4g4-cj8f-3cr9 (GitHub-reviewed advisory GHSA-f4g4-cj8f-3cr9 lists affected ranges: PyPI nova >=13.0.0 =14.0.0 =15.0.1 <15.0.2)

Commands are suggestions: review each one before running it.

Loading voting…