Drupal access bypass vulnerability
CVE-2017-6928GHSA-66mv-q8r2-hj8w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 7.57; drupal/drupal 7.57), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 7.0, < 7.57
- Fixed in
- 7.57
Packagist drupal/drupal
- Affected
- >= 7.0, < 7.57
- Fixed in
- 7.57
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-66mv-q8r2-hj8w lists affected ranges: Packagist drupal/core >=7.0 =7.0 <7.57
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2017-6928: 1.02% estimated exploitation activity in the next 30 days; percentile 63.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-66mv-q8r2-hj8w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-6928 Advisory: Drupal access bypass vulnerability IDs: CVE-2017-6928, GHSA-66mv-q8r2-hj8w Record: https://patchnext.com/advisories/cve-2017-6928 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 7.57; drupal/drupal 7.57. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 7.0, < 7.57; fixed in 7.57 - Packagist drupal/drupal: affected >= 7.0, < 7.57; fixed in 7.57 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. - Packagist drupal/drupal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core, drupal/drupal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-66mv-q8r2-hj8w (GitHub-reviewed advisory GHSA-66mv-q8r2-hj8w lists affected ranges: Packagist drupal/core >=7.0 =7.0 <7.57) Commands are suggestions: review each one before running it.
Loading voting…