Drupal REST API can bypass comment approval
CVE-2017-6924GHSA-p8g6-5mg7-9r5q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.3.7; drupal/drupal 8.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.0, < 8.3.7
- Fixed in
- 8.3.7
Packagist drupal/drupal
- Affected
- >= 8.0, < 8.3.7
- Fixed in
- 8.3.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p8g6-5mg7-9r5q lists affected ranges: Packagist drupal/core >=8.0 =8.0 <8.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2017-6924: 2.10% estimated exploitation activity in the next 30 days; percentile 81.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Drupal 8 prior to 8.3.7; When using the REST API, users without the correct permission can post comments via REST that are approved even if the user does not have permission to post approved comments. This issue only affects sites that have the RESTful Web Services (rest) module enabled, the comment entity REST resource enabled, and where an attacker can access a user account on the site with permissions to post comments, or where anonymous users can post comments.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p8g6-5mg7-9r5q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-6924 Advisory: Drupal REST API can bypass comment approval IDs: CVE-2017-6924, GHSA-p8g6-5mg7-9r5q Record: https://patchnext.com/advisories/cve-2017-6924 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.3.7; drupal/drupal 8.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.0, < 8.3.7; fixed in 8.3.7 - Packagist drupal/drupal: affected >= 8.0, < 8.3.7; fixed in 8.3.7 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. - Packagist drupal/drupal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core, drupal/drupal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p8g6-5mg7-9r5q (GitHub-reviewed advisory GHSA-p8g6-5mg7-9r5q lists affected ranges: Packagist drupal/core >=8.0 =8.0 <8.3.7) Commands are suggestions: review each one before running it.
Loading voting…