Skip to content

← Actionable
Medium, CVSS 5.9

Drupal file REST resource does not properly validate

CVE-2017-6921GHSA-h377-287m-w2r9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.3.4; drupal/drupal 8.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2017-6921: 1.83% estimated exploitation activity in the next 30 days; percentile 78.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Drupal 8 prior to 8.3.4; The file REST resource does not properly validate some fields when manipulating files. A site is only affected by this if the site has the RESTful Web Services (rest) module enabled, the file REST resource is enabled and allows PATCH requests, and an attacker can get or register a user account on the site with permissions to upload files and to modify the file resource.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h377-287m-w2r9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-6921

Advisory: Drupal file REST resource does not properly validate
IDs: CVE-2017-6921, GHSA-h377-287m-w2r9
Record: https://patchnext.com/advisories/cve-2017-6921 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.3.4; drupal/drupal 8.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.0, < 8.3.4; fixed in 8.3.4
- Packagist drupal/drupal: affected >= 8.0, < 8.3.4; fixed in 8.3.4

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h377-287m-w2r9 (GitHub-reviewed advisory GHSA-h377-287m-w2r9 lists affected ranges: Packagist drupal/core >=8.0 =8.0 <8.3.4)

Commands are suggestions: review each one before running it.

Loading voting…