Expected Behavior Violation in Apache Tomcat
CVE-2017-5651GHSA-9hg2-395j-83rm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 9.0.0.M19, 8.5.13; org.apache.tomcat.embed:tomcat-embed-core 9.0.0.M19, 8.5.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 9.0.0.M1, <= 9.0.0.M18>= 8.5.0, <= 8.5.12
- Fixed in
- 9.0.0.M19, 8.5.13
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 9.0.0.M1, <= 9.0.0.M18>= 8.5.0, <= 8.5.12
- Fixed in
- 9.0.0.M19, 8.5.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hg2-395j-83rm lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=9.0.0.M1 =8.5.0 =9.0.0.M1 =8.5.0 <=8.5.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-5651: 7.75% estimated exploitation activity in the next 30 days; percentile 94.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Tomcat 9.0.0.M1 to 9.0.0.M18 and 8.5.0 to 8.5.12, the refactoring of the HTTP connectors introduced a regression in the send file processing. If the send file processing completed quickly, it was possible for the Processor to be added to the processor cache twice. This could result in the same Processor being used for multiple requests which in turn could lead to unexpected errors and/or response mix-up.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9hg2-395j-83rm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-5651 Advisory: Expected Behavior Violation in Apache Tomcat IDs: CVE-2017-5651, GHSA-9hg2-395j-83rm Record: https://patchnext.com/advisories/cve-2017-5651 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 9.0.0.M19, 8.5.13; org.apache.tomcat.embed:tomcat-embed-core 9.0.0.M19, 8.5.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 9.0.0.M1, <= 9.0.0.M18; >= 8.5.0, <= 8.5.12; fixed in 9.0.0.M19, 8.5.13 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.0.M1, <= 9.0.0.M18; >= 8.5.0, <= 8.5.12; fixed in 9.0.0.M19, 8.5.13 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9hg2-395j-83rm (GitHub-reviewed advisory GHSA-9hg2-395j-83rm lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=9.0.0.M1 =8.5.0 =9.0.0.M1 =8.5.0 <=8.5.12) Commands are suggestions: review each one before running it.
Loading voting…