Skip to content

← Actionable
High, CVSS 7.4

Apache Camel's Validation Component is vulnerable against SSRF via remote DTDs and XXE.

CVE-2017-5643GHSA-vq9j-jh62-5hmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-core 2.18.2, 2.17.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
EPSS
  • CVE-2017-5643: 5.86% estimated exploitation activity in the next 30 days; percentile 93.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: The Validation Component of Apache Camel evaluates DTD headers of XML stream sources, although a validation against XML schemas (XSD) is executed. Remote attackers can use this feature to make Server-Side Request Forgery (SSRF) attacks by sending XML documents with remote DTDs URLs or XML External Entities (XXE). The vulnerability is not given for SAX or StAX sources. Mitigation: 2.17.x users should upgrade to 2.17.6, 2.18.x users should upgrade to 2.18.3. The JIRA tickets https://issues.apache.org/jira/browse/CAMEL-10894 refers to the various commits that resolved the issue, and have more details.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vq9j-jh62-5hmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-5643

Advisory: Apache Camel's Validation Component is vulnerable against SSRF via remote DTDs and XXE.
IDs: CVE-2017-5643, GHSA-vq9j-jh62-5hmp
Record: https://patchnext.com/advisories/cve-2017-5643 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-core 2.18.2, 2.17.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-core: affected < 2.17.6; >= 2.18.0, < 2.18.2; fixed in 2.18.2, 2.17.6

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vq9j-jh62-5hmp (GitHub-reviewed advisory GHSA-vq9j-jh62-5hmp lists affected ranges: Maven org.apache.camel:camel-core >=0 =2.18.0 <2.18.2)

Commands are suggestions: review each one before running it.

Loading voting…