SaltStack Salt Authentication Bypass when using the local_batch client from salt-api
CVE-2017-5192GHSA-f2h7-4f84-8qrm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (salt 2016.11.2, 2016.3.5, 2015.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI salt
- Affected
- < 2015.8.13>= 2016.3.0, < 2016.3.5>= 2016.11.0, < 2016.11.2
- Fixed in
- 2015.8.13, 2016.11.2, 2016.3.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f2h7-4f84-8qrm lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.0 <2016.11.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f2h7-4f84-8qrm lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.0 <2016.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-5192: 1.70% estimated exploitation activity in the next 30 days; percentile 77.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using the localbatch client from salt-api in SaltStack Salt before 2015.8.13, 2016.3.x before 2016.3.5, and 2016.11.x before 2016.11.2, external authentication is not respected, enabling all authentication to be bypassed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f2h7-4f84-8qrm
- Revision 1 · created ·
Published from osv record GHSA-f2h7-4f84-8qrm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-5192 Advisory: SaltStack Salt Authentication Bypass when using the local_batch client from salt-api IDs: CVE-2017-5192, GHSA-f2h7-4f84-8qrm Record: https://patchnext.com/advisories/cve-2017-5192 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: salt 2016.11.2, 2016.3.5, 2015.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI salt: affected < 2015.8.13; >= 2016.3.0, < 2016.3.5; >= 2016.11.0, < 2016.11.2; fixed in 2015.8.13, 2016.11.2, 2016.3.5 ## Suggested inspection (read-only) - `python -m pip show salt`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on salt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f2h7-4f84-8qrm (OSV record GHSA-f2h7-4f84-8qrm lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.0 <2016.11.2 (fixed)) - Verified: https://github.com/advisories/GHSA-f2h7-4f84-8qrm (GitHub-reviewed advisory GHSA-f2h7-4f84-8qrm lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.0 <2016.11.2) Commands are suggestions: review each one before running it.
Loading voting…