Skip to content

← Actionable
High, CVSS 8.1

Deserialization of Untrusted Data in Spring Security

CVE-2017-4995GHSA-vhrg-v3cv-p247

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-core 5.0.0.M2, 4.2.3.RELEASE), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-vhrg-v3cv-p247 lists affected ranges: Maven org.springframework.security:spring-security-core >=5.0.0.M1 =4.2.0.RELEASE <=4.2.2.RELEASE

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-4995: 2.55% estimated exploitation activity in the next 30 days; percentile 85.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Pivotal Spring Security 4.2.0.RELEASE through 4.2.2.RELEASE, and Spring Security 5.0.0.M1. When configured to enable default typing, Jackson contained a deserialization vulnerability that could lead to arbitrary code execution. Jackson fixed this vulnerability by blacklisting known "deserialization gadgets." Spring Security configures Jackson with global default typing enabled, which means that (through the previous exploit) arbitrary code could be executed if all of the following is true: (1) Spring Security's Jackson support is being leveraged by invoking SecurityJackson2Modules.getModules(ClassLoader) or SecurityJackson2Modules.enableDefaultTyping(ObjectMapper); (2) Jackson is used to deserialize data that is not trusted (Spring Security does not perform deserialization using Jackson, so this is an explicit choice of the user); and (3) there is an unknown (Jackson is not blacklisting it already) "deserialization gadget" that allows code execution present…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vhrg-v3cv-p247

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-4995

Advisory: Deserialization of Untrusted Data in Spring Security
IDs: CVE-2017-4995, GHSA-vhrg-v3cv-p247
Record: https://patchnext.com/advisories/cve-2017-4995 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-core 5.0.0.M2, 4.2.3.RELEASE. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-core: affected >= 5.0.0.M1, <= 5.0.0.M1; >= 4.2.0.RELEASE, <= 4.2.2.RELEASE; fixed in 4.2.3.RELEASE, 5.0.0.M2

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vhrg-v3cv-p247 (GitHub-reviewed advisory GHSA-vhrg-v3cv-p247 lists affected ranges: Maven org.springframework.security:spring-security-core >=5.0.0.M1 =4.2.0.RELEASE <=4.2.2.RELEASE)

Commands are suggestions: review each one before running it.

Loading voting…