Cloud Foundry UAA password reset vulnerability
CVE-2017-4991GHSA-cgrg-x34r-78f3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 3.17.0, 3.9.12, 3.6.10, 2.7.4.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.cloudfoundry.identity:cloudfoundry-identity-server
- Affected
- >= 2.0.0, < 2.7.4.16>= 3.0.0, < 3.6.10>= 3.7.0, < 3.9.12>= 3.10.0, < 3.17.0
- Fixed in
- 3.9.12, 2.7.4.16, 3.17.0, 3.6.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cgrg-x34r-78f3 lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=2.0.0 =3.0.0 =3.7.0 =3.10.0 <3.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-4991: 0.94% estimated exploitation activity in the next 30 days; percentile 60.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v260; UAA release 2.x versions prior to v2.7.4.16, 3.6.x versions prior to v3.6.10, 3.9.x versions prior to v3.9.12, and other versions prior to v3.17.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.14, 24.x versions prior to v24.9, 30.x versions prior to 30.2, and other versions prior to v36. Privileged users in one zone are allowed to perform a password reset for users in a different zone.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cgrg-x34r-78f3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-4991 Advisory: Cloud Foundry UAA password reset vulnerability IDs: CVE-2017-4991, GHSA-cgrg-x34r-78f3 Record: https://patchnext.com/advisories/cve-2017-4991 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 3.17.0, 3.9.12, 3.6.10, 2.7.4.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected >= 2.0.0, < 2.7.4.16; >= 3.0.0, < 3.6.10; >= 3.7.0, < 3.9.12; >= 3.10.0, < 3.17.0; fixed in 3.9.12, 2.7.4.16, 3.17.0, 3.6.10 ## Suggested inspection (read-only) - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cgrg-x34r-78f3 (GitHub-reviewed advisory GHSA-cgrg-x34r-78f3 lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=2.0.0 =3.0.0 =3.7.0 =3.10.0 <3.17.0) Commands are suggestions: review each one before running it.
Loading voting…