Truncated packet could crash via OOB read
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 4.0.0, < 4.7.3>= 5.0.0, < 6.0.0>= 6.0.0, < 6.9.5>= 7.0.0, < 7.5.0
- Fixed in
- 7.5.0, 4.7.3, 6.9.5
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2017-3731 to 2017-01-31.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 3 lists CVE-2017-3731 affecting node >=4.0.0 =5.0.0 =6.0.0 =7.0.0 <7.5.0
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2017-3731: 57.32% estimated exploitation activity in the next 30 days; percentile 99.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This is a moderate severity flaw in OpenSSL. By default, Node.js disables RC4 so most users are not affected. As RC4 can be enabled programmatically, it is possible for a Node.js developer to craft code that may be vulnerable to this flaw. Any user activating RC4 in their codebase should prioritise this update. All active versions of Node.js are affected, but the severity is very low for most users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:3
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-3731 Advisory: Truncated packet could crash via OOB read IDs: CVE-2017-3731 Record: https://patchnext.com/advisories/cve-2017-3731 (revision 2, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: node 7.5.0, 6.9.5, 4.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 4.0.0, < 4.7.3; >= 5.0.0, < 6.0.0; >= 6.0.0, < 6.9.5; >= 7.0.0, < 7.5.0; fixed in 7.5.0, 4.7.3, 6.9.5 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2017-3731 to 2017-01-31.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/3.json (Node.js security working group core entry 3 lists CVE-2017-3731 affecting node >=4.0.0 =5.0.0 =6.0.0 =7.0.0 <7.5.0) Commands are suggestions: review each one before running it.
Loading voting…