Improper Neutralization of Input During Web Page Generation in Apache Hadoop
CVE-2017-3161GHSA-qm7f-r83w-3p46
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-client 2.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hadoop:hadoop-client
- Affected
- <= 2.6.5
- Fixed in
- 2.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qm7f-r83w-3p46 lists affected ranges: Maven org.apache.hadoop:hadoop-client >=0 <=2.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-3161: 3.87% estimated exploitation activity in the next 30 days; percentile 90.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The HDFS web UI in Apache Hadoop before 2.7.0 is vulnerable to a cross-site scripting (XSS) attack through an unescaped query parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qm7f-r83w-3p46
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-3161 Advisory: Improper Neutralization of Input During Web Page Generation in Apache Hadoop IDs: CVE-2017-3161, GHSA-qm7f-r83w-3p46 Record: https://patchnext.com/advisories/cve-2017-3161 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-client 2.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hadoop:hadoop-client: affected <= 2.6.5; fixed in 2.7.0 ## Suggested inspection (read-only) - Maven org.apache.hadoop:hadoop-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hadoop:hadoop-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qm7f-r83w-3p46 (GitHub-reviewed advisory GHSA-qm7f-r83w-3p46 lists affected ranges: Maven org.apache.hadoop:hadoop-client >=0 <=2.6.5) Commands are suggestions: review each one before running it.
Loading voting…