Cross-site Scripting in Apache Atlas
CVE-2017-3152GHSA-9xwq-72vp-5j3c
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-atlas
- Affected
- every version
- Fixed in
- no fixed version recorded
Maven org.apache.atlas:atlas-common
- Affected
- >= 0.6.0-incubating, < 0.7.1-incubating
- Fixed in
- 0.7.1-incubating
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2017-108 lists affected ranges: PyPI apache-atlas >=0
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9xwq-72vp-5j3c lists affected ranges: Maven org.apache.atlas:atlas-common >=0.6.0-incubating <0.7.1-incubating
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2017-3152: 2.21% estimated exploitation activity in the next 30 days; percentile 82.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Atlas versions 0.6.0-incubating and 0.7.0-incubating were found vulnerable to DOM XSS in the edit-tag functionality.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9xwq-72vp-5j3c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record PYSEC-2017-108
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-3152 Advisory: Cross-site Scripting in Apache Atlas IDs: CVE-2017-3152, GHSA-9xwq-72vp-5j3c Record: https://patchnext.com/advisories/cve-2017-3152 (revision 3, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.atlas:atlas-common 0.7.1-incubating. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-atlas: affected every version - Maven org.apache.atlas:atlas-common: affected >= 0.6.0-incubating, < 0.7.1-incubating; fixed in 0.7.1-incubating ## Suggested inspection (read-only) - `python -m pip show apache-atlas`: prints the installed version. Run with the environment that serves production active. - Maven org.apache.atlas:atlas-common: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-atlas, org.apache.atlas:atlas-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2017-108 (OSV record PYSEC-2017-108 lists affected ranges: PyPI apache-atlas >=0) - Verified: https://github.com/advisories/GHSA-9xwq-72vp-5j3c (GitHub-reviewed advisory GHSA-9xwq-72vp-5j3c lists affected ranges: Maven org.apache.atlas:atlas-common >=0.6.0-incubating <0.7.1-incubating) Commands are suggestions: review each one before running it.
Loading voting…