Skip to content

← Actionable
High, CVSS 8.6amended

OpenStack Identity service (keystone) Incorrect Authorization

CVE-2017-2673GHSA-j36m-hv43-7w7m

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI keystone

    Affected
    >= 9.0.0, <= 9.3.0>= 10.0.0, <= 10.0.1>= 11.0.0, <= 11.0.0
    Fixed in
    11.0.1, 10.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2017-2673: 2.30% estimated exploitation activity in the next 30 days; percentile 83.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An authorization-check flaw was discovered in federation configurations of the OpenStack Identity service (keystone). An authenticated federated user could request permissions to a project and unintentionally be granted all related roles including administrative roles.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j36m-hv43-7w7m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j36m-hv43-7w7m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-2673

Advisory: OpenStack Identity service (keystone) Incorrect Authorization
IDs: CVE-2017-2673, GHSA-j36m-hv43-7w7m
Record: https://patchnext.com/advisories/cve-2017-2673 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: keystone 11.0.1, 10.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI keystone: affected >= 9.0.0, <= 9.3.0; >= 10.0.0, <= 10.0.1; >= 11.0.0, <= 11.0.0; fixed in 11.0.1, 10.0.2

## Suggested inspection (read-only)
- `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keystone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j36m-hv43-7w7m (OSV record GHSA-j36m-hv43-7w7m lists affected ranges: PyPI keystone >=9.0.0 =10.0.0 =11.0.0 <11.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-j36m-hv43-7w7m (GitHub-reviewed advisory GHSA-j36m-hv43-7w7m lists affected ranges: PyPI keystone >=9.0.0 =10.0.0 =11.0.0 <=11.0.0)

Commands are suggestions: review each one before running it.

Loading voting…