Skip to content

← Actionable
Medium, CVSS 6.5

Undertow-core vulnerable to HTTP Request Smuggling

CVE-2017-2666GHSA-mcfm-h73v-635m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.undertow:undertow-core 1.4.17, 1.3.31), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2017-2666: 3.09% estimated exploitation activity in the next 30 days; percentile 87.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

It was discovered in Undertow that the code that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mcfm-h73v-635m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-2666

Advisory: Undertow-core vulnerable to HTTP Request Smuggling
IDs: CVE-2017-2666, GHSA-mcfm-h73v-635m
Record: https://patchnext.com/advisories/cve-2017-2666 (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.undertow:undertow-core 1.4.17, 1.3.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.undertow:undertow-core: affected < 1.3.31; >= 1.4.0, < 1.4.17; fixed in 1.4.17, 1.3.31

## Suggested inspection (read-only)
- Maven io.undertow:undertow-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.undertow:undertow-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mcfm-h73v-635m (GitHub-reviewed advisory GHSA-mcfm-h73v-635m lists affected ranges: Maven io.undertow:undertow-core >=0 =1.4.0 <1.4.17)

Commands are suggestions: review each one before running it.

Loading voting…