Exposure of Sensitive Information to an Unauthorized Actor in Jenkins
CVE-2017-2600GHSA-wj5c-j656-h5fw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 2.44, 2.32.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.main:jenkins-core
- Affected
- <= 2.32.1>= 2.34, <= 2.43
- Fixed in
- 2.32.2, 2.44
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wj5c-j656-h5fw lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.34 <=2.43
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2017-2600: 1.03% estimated exploitation activity in the next 30 days; percentile 63.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Jenkins before versions 2.44 and 2.32.2, node monitor data could be viewed by low privilege users via the remote API. These included system configuration and runtime information of these nodes (SECURITY-343).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wj5c-j656-h5fw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-2600 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Jenkins IDs: CVE-2017-2600, GHSA-wj5c-j656-h5fw Record: https://patchnext.com/advisories/cve-2017-2600 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 2.44, 2.32.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.main:jenkins-core: affected <= 2.32.1; >= 2.34, <= 2.43; fixed in 2.32.2, 2.44 ## Suggested inspection (read-only) - Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.main:jenkins-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wj5c-j656-h5fw (GitHub-reviewed advisory GHSA-wj5c-j656-h5fw lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.34 <=2.43) Commands are suggestions: review each one before running it.
Loading voting…