Skip to content

← Actionable
Critical, CVSS 9.8amended

express-param vulnerable to Improper Handling of Extra Parameters

CVE-2017-20160GHSA-fr54-72wr-cqvq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-param 1.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-20160: 0.88% estimated exploitation activity in the next 30 days; percentile 59.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in flitto express-param up to 0.x. It has been classified as critical. This affects an unknown part of the file lib/fetchParams.js. The manipulation leads to improper handling of extra parameters. It is possible to initiate the attack remotely. Upgrading to version 1.0.0 can address this issue. The name of the patch is db94f7391ad0a16dcfcba8b9be1af385b25c42db. It is recommended to upgrade the affected component. The identifier VDB-217149 was assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fr54-72wr-cqvq

  2. Revision 1 · created ·

    Published from osv record GHSA-fr54-72wr-cqvq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-20160

Advisory: express-param vulnerable to Improper Handling of Extra Parameters
IDs: CVE-2017-20160, GHSA-fr54-72wr-cqvq
Record: https://patchnext.com/advisories/cve-2017-20160 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: express-param 1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm express-param: affected < 1.0.0; fixed in 1.0.0

## Suggested inspection (read-only)
- `npm ls express-param --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on express-param.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fr54-72wr-cqvq (OSV record GHSA-fr54-72wr-cqvq lists affected ranges: npm express-param >=0 <1.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fr54-72wr-cqvq (GitHub-reviewed advisory GHSA-fr54-72wr-cqvq lists affected ranges: npm express-param >=0 <1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…