Skip to content

← Actionable
Medium, CVSS 6.1

Yii2 FileAPI Widget vulnerable to Cross-site Scripting

CVE-2017-20158GHSA-j82x-fh8h-326g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vova07/yii2-fileapi-widget 0.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-20158: 0.60% estimated exploitation activity in the next 30 days; percentile 48.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 can address this issue. The name of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j82x-fh8h-326g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-20158

Advisory: Yii2 FileAPI Widget vulnerable to Cross-site Scripting
IDs: CVE-2017-20158, GHSA-j82x-fh8h-326g
Record: https://patchnext.com/advisories/cve-2017-20158 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vova07/yii2-fileapi-widget 0.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist vova07/yii2-fileapi-widget: affected < 0.1.9; fixed in 0.1.9

## Suggested inspection (read-only)
- Packagist vova07/yii2-fileapi-widget: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vova07/yii2-fileapi-widget.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j82x-fh8h-326g (GitHub-reviewed advisory GHSA-j82x-fh8h-326g lists affected ranges: Packagist vova07/yii2-fileapi-widget >=0 <0.1.9)

Commands are suggestions: review each one before running it.

Loading voting…