Mattermost Server has Improper Authorization for Integration Requests
CVE-2017-18916GHSA-x33g-375j-jhf7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 3.8.2, 3.7.5, 3.6.7-0.20170420152529-0968e4079e0a), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server
- Affected
- < 3.6.7-0.20170420152529-0968e4079e0a>= 3.7.0, < 3.7.5>= 3.8.0, < 3.8.2
- Fixed in
- 3.6.7-0.20170420152529-0968e4079e0a, 3.7.5, 3.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x33g-375j-jhf7 lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =3.7.0 =3.8.0 <3.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-18916: 0.78% estimated exploitation activity in the next 30 days; percentile 55.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. API endpoint access control does not honor an integration permission restriction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x33g-375j-jhf7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-18916 Advisory: Mattermost Server has Improper Authorization for Integration Requests IDs: CVE-2017-18916, GHSA-x33g-375j-jhf7 Record: https://patchnext.com/advisories/cve-2017-18916 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 3.8.2, 3.7.5, 3.6.7-0.20170420152529-0968e4079e0a. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-server: affected < 3.6.7-0.20170420152529-0968e4079e0a; >= 3.7.0, < 3.7.5; >= 3.8.0, < 3.8.2; fixed in 3.6.7-0.20170420152529-0968e4079e0a, 3.7.5, 3.8.2 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x33g-375j-jhf7 (GitHub-reviewed advisory GHSA-x33g-375j-jhf7 lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =3.7.0 =3.8.0 <3.8.2) Commands are suggestions: review each one before running it.
Loading voting…