Mattermost Server is vulnerable to Path Traversal when files are stored locally
CVE-2017-18876GHSA-hjqh-j6rj-gh8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60c), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server
- Affected
- < 4.1.2-0.20171004201910-6be8113eb60c>= 4.2.0-rc1.0.20171004154238-fadd9514f6e7, < 4.2.1-0.20171004194140-6d3cb2ce07fc>= 4.3.0-rc1, < 4.3.0
- Fixed in
- 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60c
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hjqh-j6rj-gh8q lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =4.2.0-rc1.0.20171004154238-fadd9514f6e7 =4.3.0-rc1 <4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-18876: 0.87% estimated exploitation activity in the next 30 days; percentile 58.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2 when local storage for files is used. A System Admin can test for the existence of an arbitrary file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hjqh-j6rj-gh8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-18876 Advisory: Mattermost Server is vulnerable to Path Traversal when files are stored locally IDs: CVE-2017-18876, GHSA-hjqh-j6rj-gh8q Record: https://patchnext.com/advisories/cve-2017-18876 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60c. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-server: affected < 4.1.2-0.20171004201910-6be8113eb60c; >= 4.2.0-rc1.0.20171004154238-fadd9514f6e7, < 4.2.1-0.20171004194140-6d3cb2ce07fc; >= 4.3.0-rc1, < 4.3.0; fixed in 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60c ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hjqh-j6rj-gh8q (GitHub-reviewed advisory GHSA-hjqh-j6rj-gh8q lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =4.2.0-rc1.0.20171004154238-fadd9514f6e7 =4.3.0-rc1 <4.3.0) Commands are suggestions: review each one before running it.
Loading voting…