Skip to content

← Actionable
Unrated

Mattermost Server is vulnerable to Directory Traversal by System Admins

CVE-2017-18874GHSA-8qg8-c7mw-6fj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost-server

    Affected
    < 4.1.2-0.20171004201910-6be8113eb60>= 4.2.0-rc1, < 4.2.1-0.20171004194140-6d3cb2ce07fc>= 4.3.0-rc1, < 4.3.0
    Fixed in
    4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2017-18874: 1.24% estimated exploitation activity in the next 30 days; percentile 69.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2 when local storage for files is used. A System Admin can achieve directory traversal.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8qg8-c7mw-6fj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-18874

Advisory: Mattermost Server is vulnerable to Directory Traversal by System Admins
IDs: CVE-2017-18874, GHSA-8qg8-c7mw-6fj7
Record: https://patchnext.com/advisories/cve-2017-18874 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost-server: affected < 4.1.2-0.20171004201910-6be8113eb60; >= 4.2.0-rc1, < 4.2.1-0.20171004194140-6d3cb2ce07fc; >= 4.3.0-rc1, < 4.3.0; fixed in 4.3.0, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.1.2-0.20171004201910-6be8113eb60

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qg8-c7mw-6fj7 (GitHub-reviewed advisory GHSA-8qg8-c7mw-6fj7 lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =4.2.0-rc1 =4.3.0-rc1 <4.3.0)

Commands are suggestions: review each one before running it.

Loading voting…