Skip to content

← Actionable
High, CVSS 7.5

Mattermost Server vulnerable to Denial of Service through @ character prefix inserted into JavaScript field names

CVE-2017-18871GHSA-jc6w-8r7f-vmp5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 4.5.0, 4.4.5, 4.3.4, 4.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jc6w-8r7f-vmp5 lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =4.3.0-rc1 =4.4.0-rc1 =4.5.0-rc1 <4.5.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2017-18871: 1.12% estimated exploitation activity in the next 30 days; percentile 66.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2. It allows attackers to cause a denial of service (application crash) via an @ character before a JavaScript field name.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jc6w-8r7f-vmp5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-18871

Advisory: Mattermost Server vulnerable to Denial of Service through `@` character prefix inserted into JavaScript field names
IDs: CVE-2017-18871, GHSA-jc6w-8r7f-vmp5
Record: https://patchnext.com/advisories/cve-2017-18871 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 4.5.0, 4.4.5, 4.3.4, 4.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost-server: affected < 4.2.2; >= 4.3.0-rc1, < 4.3.4; >= 4.4.0-rc1, < 4.4.5; >= 4.5.0-rc1, < 4.5.0; fixed in 4.3.4, 4.5.0, 4.2.2, 4.4.5

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jc6w-8r7f-vmp5 (GitHub-reviewed advisory GHSA-jc6w-8r7f-vmp5 lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =4.3.0-rc1 =4.4.0-rc1 =4.5.0-rc1 <4.5.0)

Commands are suggestions: review each one before running it.

Loading voting…