Skip to content

← Actionable
High, CVSS 8.7amended

graphite.composer.views.send_email vulnerable to SSRF

CVE-2017-18638GHSA-vfj6-275q-4pvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphite-web 1.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2017-18638: 15.30% estimated exploitation activity in the next 30 days; percentile 96.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact sendemail in graphite-web/webapp/graphite/composer/views.py in Graphite through 1.1.5 is vulnerable to SSRF. The vulnerable SSRF endpoint can be used by an attacker to have the Graphite web server request any resource. The response to this SSRF request is encoded into an image file and then sent to an e-mail address that can be supplied by the attacker. Thus, an attacker can exfiltrate any information. Email will be send through SMTP server configured in Graphite, by default it's 'localhost' Patches Problem was patched in Graphite-web 1.1.6. Also patches was released for graphite-web 1.0.x and 0.9.x, and we'll discuss releases of non-supported branches later. Workarounds You can manually remove function sendemail from file webapp/graphite/composer/views.py. This function are not in use and will not affect your Graphite installation. References For more information check this graphite-web Github issue #2008 For more information If you have any questions or comments about this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vfj6-275q-4pvm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vfj6-275q-4pvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-18638

Advisory: graphite.composer.views.send_email vulnerable to SSRF
IDs: CVE-2017-18638, GHSA-vfj6-275q-4pvm
Record: https://patchnext.com/advisories/cve-2017-18638 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: graphite-web 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI graphite-web: affected < 1.1.6; fixed in 1.1.6

## Suggested inspection (read-only)
- `python -m pip show graphite-web`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on graphite-web.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vfj6-275q-4pvm (OSV record GHSA-vfj6-275q-4pvm lists affected ranges: PyPI graphite-web >=0 <1.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-vfj6-275q-4pvm (GitHub-reviewed advisory GHSA-vfj6-275q-4pvm lists affected ranges: PyPI graphite-web >=0 <1.1.6)

Commands are suggestions: review each one before running it.

Loading voting…