Skip to content

← Actionable
Critical, CVSS 9.8

phpMyAdmin Improper Privilege Management

CVE-2017-18264GHSA-5868-g58j-vrj5

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpmyadmin/phpmyadmin

    Affected
    >= 4.0, < 4.0.10.20>= 4.7.0-beta1, < 4.7.0>= 4.4.0, <= 4.4.15.10>= 4.6.0, <= 4.6.6
    Fixed in
    4.7.0, 4.0.10.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-18264: 2.82% estimated exploitation activity in the next 30 days; percentile 86.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5868-g58j-vrj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-18264

Advisory: phpMyAdmin Improper Privilege Management
IDs: CVE-2017-18264, GHSA-5868-g58j-vrj5
Record: https://patchnext.com/advisories/cve-2017-18264 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpmyadmin/phpmyadmin 4.7.0, 4.0.10.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.0, < 4.0.10.20; >= 4.7.0-beta1, < 4.7.0; >= 4.4.0, <= 4.4.15.10; >= 4.6.0, <= 4.6.6; fixed in 4.7.0, 4.0.10.20

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5868-g58j-vrj5 (GitHub-reviewed advisory GHSA-5868-g58j-vrj5 lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.0 =4.7.0-beta1 =4.4.0 =4.6.0 <=4.6.6)

Commands are suggestions: review each one before running it.

Loading voting…