Skip to content

← Actionable
High, CVSS 8.1

SimpleSAMLphp Signature validation bypass

CVE-2017-18122GHSA-j4qf-3w33-8cgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/simplesamlphp 1.14.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-18122: 1.09% estimated exploitation activity in the next 30 days; percentile 65.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. A SimpleSAMLphp Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j4qf-3w33-8cgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-18122

Advisory: SimpleSAMLphp Signature validation bypass
IDs: CVE-2017-18122, GHSA-j4qf-3w33-8cgc
Record: https://patchnext.com/advisories/cve-2017-18122 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/simplesamlphp 1.14.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist simplesamlphp/simplesamlphp: affected < 1.14.17; fixed in 1.14.17

## Suggested inspection (read-only)
- Packagist simplesamlphp/simplesamlphp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplesamlphp/simplesamlphp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j4qf-3w33-8cgc (GitHub-reviewed advisory GHSA-j4qf-3w33-8cgc lists affected ranges: Packagist simplesamlphp/simplesamlphp >=0 <1.14.17)

Commands are suggestions: review each one before running it.

Loading voting…