GitHub Git LFS Arbitrary command execution vulnerability
CVE-2017-17831GHSA-w4xh-w33p-4v29
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/git-lfs/git-lfs 2.1.1-0.20170519163204-f913f5f9c7c6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.1.1-0.20170519163204-f913f5f9c7c6
- Fixed in
- 2.1.1-0.20170519163204-f913f5f9c7c6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w4xh-w33p-4v29 lists affected ranges: Go github.com/git-lfs/git-lfs >=0 <2.1.1-0.20170519163204-f913f5f9c7c6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-17831: 3.68% estimated exploitation activity in the next 30 days; percentile 89.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
GitHub Git LFS before 2.1.1 allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, located on a url = line in a .lfsconfig file within a repository. Specific Go Packages Affected github.com/git-lfs/git-lfs/lfsapi
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w4xh-w33p-4v29
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-17831 Advisory: GitHub Git LFS Arbitrary command execution vulnerability IDs: CVE-2017-17831, GHSA-w4xh-w33p-4v29 Record: https://patchnext.com/advisories/cve-2017-17831 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/git-lfs/git-lfs 2.1.1-0.20170519163204-f913f5f9c7c6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/git-lfs/git-lfs: affected < 2.1.1-0.20170519163204-f913f5f9c7c6; fixed in 2.1.1-0.20170519163204-f913f5f9c7c6 ## Suggested inspection (read-only) - Go github.com/git-lfs/git-lfs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/git-lfs/git-lfs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w4xh-w33p-4v29 (GitHub-reviewed advisory GHSA-w4xh-w33p-4v29 lists affected ranges: Go github.com/git-lfs/git-lfs >=0 <2.1.1-0.20170519163204-f913f5f9c7c6) Commands are suggestions: review each one before running it.
Loading voting…