Skip to content

← Actionable
High, CVSS 7.5amended

auth0-js Privilege Escalation Vulnerability

CVE-2017-17068GHSA-3rpr-mg43-xhq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-js 8.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm auth0-js

    Affected
    < 8.12.0
    Fixed in
    8.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2017-17068: 1.42% estimated exploitation activity in the next 30 days; percentile 72.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions &lt; 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3rpr-mg43-xhq4

  2. Revision 1 · created ·

    Published from osv record GHSA-3rpr-mg43-xhq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-17068

Advisory: auth0-js Privilege Escalation Vulnerability
IDs: CVE-2017-17068, GHSA-3rpr-mg43-xhq4
Record: https://patchnext.com/advisories/cve-2017-17068 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-js 8.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-js: affected < 8.12.0; fixed in 8.12.0

## Suggested inspection (read-only)
- `npm ls auth0-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3rpr-mg43-xhq4 (OSV record GHSA-3rpr-mg43-xhq4 lists affected ranges: npm auth0-js >=0 <8.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3rpr-mg43-xhq4 (GitHub-reviewed advisory GHSA-3rpr-mg43-xhq4 lists affected ranges: npm auth0-js >=0 <8.12.0)

Commands are suggestions: review each one before running it.

Loading voting…