passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token
CVE-2017-16897GHSA-77fw-rf4v-vfp9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (passport-wsfed-saml2 3.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.0.5
- Fixed in
- 3.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-77fw-rf4v-vfp9 lists affected ranges: npm passport-wsfed-saml2 >=0 <3.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-77fw-rf4v-vfp9 lists affected ranges: npm passport-wsfed-saml2 >=0 <3.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-16897: 1.38% estimated exploitation activity in the next 30 days; percentile 72.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Information Please note that this is not a new disclosure, and is previously reported in our SECURITY-NOTICE.md which we removed in favor of github advisory. Overview This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider: - signs SAML response and signs assertion - does not sign SAML response and signs assertion Am I affected? You may be affected if you use SAML2 protocol with passport-wsfed-saml2 versions below 3.0.5 and your SAML identity Provider: 1. signs SAML response and signs assertion; or 2. does not sign SAML response and signs assertion How do I fix it? You may fix this vulnerability by upgrading your library to version 3.0.5 or above. Will the fix impact my users? This fix patches the library that your application runs, but will not impact your users, their current state, or any existing sessions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-77fw-rf4v-vfp9
- Revision 1 · created ·
Published from osv record GHSA-77fw-rf4v-vfp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16897 Advisory: passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token IDs: CVE-2017-16897, GHSA-77fw-rf4v-vfp9 Record: https://patchnext.com/advisories/cve-2017-16897 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: passport-wsfed-saml2 3.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm passport-wsfed-saml2: affected < 3.0.5; fixed in 3.0.5 ## Suggested inspection (read-only) - `npm ls passport-wsfed-saml2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on passport-wsfed-saml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-77fw-rf4v-vfp9 (OSV record GHSA-77fw-rf4v-vfp9 lists affected ranges: npm passport-wsfed-saml2 >=0 <3.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-77fw-rf4v-vfp9 (GitHub-reviewed advisory GHSA-77fw-rf4v-vfp9 lists affected ranges: npm passport-wsfed-saml2 >=0 <3.0.5) Commands are suggestions: review each one before running it.
Loading voting…