Skip to content

← Actionable
Medium, CVSS 5.4

Kirby XSS Vulnerability

CVE-2017-16807GHSA-275c-v3rc-xghx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 2.5.7, 2.4.2, 2.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 2.3.3>= 2.4, < 2.4.2>= 2.5, < 2.5.7
    Fixed in
    2.4.2, 2.3.3, 2.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-16807: 2.42% estimated exploitation activity in the next 30 days; percentile 84.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-275c-v3rc-xghx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16807

Advisory: Kirby XSS Vulnerability
IDs: CVE-2017-16807, GHSA-275c-v3rc-xghx
Record: https://patchnext.com/advisories/cve-2017-16807 (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 2.5.7, 2.4.2, 2.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 2.3.3; >= 2.4, < 2.4.2; >= 2.5, < 2.5.7; fixed in 2.4.2, 2.3.3, 2.5.7

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-275c-v3rc-xghx (GitHub-reviewed advisory GHSA-275c-v3rc-xghx lists affected ranges: Packagist getkirby/cms >=0 =2.4 =2.5 <2.5.7)

Commands are suggestions: review each one before running it.

Loading voting…