Skip to content

← Actionable
High, CVSS 7.5

Symfony Directory Traversal

CVE-2017-16654GHSA-c49r-8gj6-768r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 3.3.13, 3.2.14, 2.8.31, 2.7.38; symfony/intl 3.3.13, 3.2.14, 2.8.31, 2.7.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.7.0, < 2.7.38>= 2.8.0, < 2.8.31>= 3.0.0, < 3.2.14>= 3.3.0, < 3.3.13
    Fixed in
    2.8.31, 2.7.38, 3.3.13, 3.2.14
  • Packagist symfony/intl

    Affected
    >= 2.7.0, < 2.7.38>= 2.8.0, < 2.8.31>= 3.0.0, < 3.2.14>= 3.3.0, < 3.3.13
    Fixed in
    2.8.31, 2.7.38, 3.3.13, 3.2.14

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-c49r-8gj6-768r lists affected ranges: Packagist symfony/intl >=2.7.0 =2.8.0 =3.0.0 =3.3.0 =2.7.0 =2.8.0 =3.0.0 =3.3.0 <3.3.13

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2017-16654: 2.68% estimated exploitation activity in the next 30 days; percentile 85.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The Intl component includes various bundle readers that are used to read resource bundles from the local filesystem. The read() methods of these classes use a path and a locale to determine the language bundle to retrieve. The locale argument value is commonly retrieved from untrusted user input (like a URL parameter). An attacker can use this argument to navigate to arbitrary directories via the dot-dot-slash attack, aka Directory Traversal.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c49r-8gj6-768r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16654

Advisory: Symfony Directory Traversal
IDs: CVE-2017-16654, GHSA-c49r-8gj6-768r
Record: https://patchnext.com/advisories/cve-2017-16654 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 3.3.13, 3.2.14, 2.8.31, 2.7.38; symfony/intl 3.3.13, 3.2.14, 2.8.31, 2.7.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.7.0, < 2.7.38; >= 2.8.0, < 2.8.31; >= 3.0.0, < 3.2.14; >= 3.3.0, < 3.3.13; fixed in 2.8.31, 2.7.38, 3.3.13, 3.2.14
- Packagist symfony/intl: affected >= 2.7.0, < 2.7.38; >= 2.8.0, < 2.8.31; >= 3.0.0, < 3.2.14; >= 3.3.0, < 3.3.13; fixed in 2.8.31, 2.7.38, 3.3.13, 3.2.14

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/intl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/intl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c49r-8gj6-768r (GitHub-reviewed advisory GHSA-c49r-8gj6-768r lists affected ranges: Packagist symfony/intl >=2.7.0 =2.8.0 =3.0.0 =3.3.0 =2.7.0 =2.8.0 =3.0.0 =3.3.0 <3.3.13)

Commands are suggestions: review each one before running it.

Loading voting…